Cisco IOS Commands Help – CCNA Commands Cheat Sheet

A good working knowledge of Cisco IOS commands is vital for your success in your Cisco exam. You will be tested on them during the switch and router simulations and also in the multiple choice questions.

Here are what we think are the most important ones you need to know along with how to apply them to live Cisco equipment. If you think we have missed any out please drop us a line to help at itexamanswers.net

boot system

Unprivileged Commands

enablelockping
telnettracerouteresume
disconnectsshexit

Privileged Commands

configure terminaldebugsetup
copy running-config startup-configerase startup-configwrite
clock setclearreload
write terminalundebug allcopy tftp startup-config
copy running-config tftpcopy tftp running-configcopy startup-config running-config
terminal monitorcopy startup-config tftp

Configure Commands

ip domain-lookupnohostname
config-registerclock timezonealias exec
logging consoledodefault interface
interfacerouterusername
ip classlessip subnet-zeroip default-gateway
ip dhcp poolenable secretip domain-name
ip hostip http serverip name-server
ip routeaccess-list (standard)access-list (extended)
ip access-listservice password-encryptioninterface loopback
endlogging bufferedbanner motd
router riprouter eigrp <As>router ospf <process id>
ip nat poolip nat inside source listip nat inside source static
ip dhcp excluded-addressenable password

Interface Commands

ip addressclock rateencapsulation
bandwidthdescriptionduplex
no shutdown / shutdownencapsulation dot1qkeepalive
ip access-groupip bandwidth-percent (EIGRP)ip directed-broadcast
ip helper-address (DHCP)ip mtuip ospf #
ip ospf costip ospf priorityip ospf network broadcast
ip ospf network nonbroadcastip ospf network point-to-pointip ospf network point-to-multipoint
ip ospf hello-intervalip ospf dead-intervalcdp enable
ip rip sendip rip receivespeed
mac-addressip split-horizon (RIP)ip split-horizon eigrp <As>
encapsulation pppppp authentication chapppp chap hostname
ppp chap passwordppp pap sent-usernameencapsulation frame-relay
frame-relay interface-dlciframe-relay map ipframe-relay inverse-arp
ip nat insideip nat outsideip nat enable
ip address dhcpppp authentication papdelay

Line console Commands

logging synchronousloginhistory size
exec-timeoutlengthlockable
passwordprivilege

Line VTY Commands 

logging synchronousloginhistory size
exec-timeoutlengthlockable
passwordprivilegeaccess-class

Show Commands

show access-listsshow Running-configshow startup-config
show running-config Interfaceshow Clockshow controllers
show debugshow frame-relay mapshow frame-relay pvc
show frame-relay lmishow hostsshow interfaces
show ip interfacesshow ip interface briefshow sessions
show tech-supportshow ip access-listsshow ip dhcp binding
show ip dhcp conflictsshow ip dhcp poolshow dhcp server
show ip eigrp interfaceshow ip eigrp neighborsshow ip eigrp topology
show ip ospf interfaceshow ip ospf interface briefshow ip ospf neighbor
show ip ospf databaseshow ip routeshow ip route rip
show ip route eigrpshow ip route ospfshow ip route connected
show ip nat translationsshow ip nat statisticsshow ip protocols
show cdp neighborsshow cdp neighbors detailshow dhcp lease
Filtering Output *

Router RIP Commands

version 2no auto-summarynetwork
passive-interfacevalidate-update-sourcepassive-interface default
maximum-pathsdistribute-listoffset-list
distancetimersneighbor

Router EIGRP Commands

no auto-summarynetworkdistance
distribute-listeigrp router-idpassive-interface
passive-interface defaultvariance (EIGRP)offset-list
distance eigrpmaximum-pathsneighbor

Router OSPF Commands

network
passive-interfacerouter-idpassive-interface default
maximum-pathsdistribute-listauto-cost reference-bandwidth
distancedistance ospfneighbor

Debug Commands

debug ip packetdebug ip packet detaildebug ip routing
debug ip eigrpdebug ip ospf adjdebug ip ospf events
debug ip ospf packetdebug ip rip

Clear Commands

clear ip route *clear ip ospf processclear ip eigrp neighbors

Switch Commands

Privilege Commands

vlan databaseconfigure

Vlan Database Commands

vlanexitshow
vtp domainvtp pruningvtp server
vtp clientvtp transparentvtp password
apply

Configure Commands

vlaninterface vlaninterface range
vtp mode servervtp mode clientvtp mode transparent
vtp domainvtp passwordspanning-tree backbonefast
vtp pruningspanning-tree portfastip default-gateway
spanning-tree vlan root primaryspanning-tree vlan root secondaryspanning-tree vlan priority
spanning-tree uplinkfast

Interface Commands

switchport mode accessswitchport mode trunkswitchport nonegotiate
spanning vlan costswitchport trunk encapsulation dot1qswitchport trunk encapsulation isl
switchport trunk native vlanspanning-tree port-priorityswitchport trunk allowed vlan
switchport access vlanswitchport port-securityswitchport port-security mac-address
spanning-tree vlan port-priorityswitchport port-security maximumswitchport port-security violation
spanning-tree costspanning-tree guard root
spanning-tree portfast

Show Commands

show vlanshow vlan briefshow interface trunk
show spanning-treeshow spanning-tree vlanshow vtp status
show port-secshow mac-address-tableshow interface

Special Keys Commands

TabReturn (at the –More– prompt)space Bar (at the –More– prompt)
Ctrl-FEsc-BEsc-F
Ctrl-ACtrl-ECtrl-D
Esc-DCtrl-WCtrl-K
Ctrl-U or Ctrl-XUp Arrow or Ctrl-PDown Arrow or Ctrl-N
Ctrl-YCtrl-ZCtrl-shift-6, x

Related Articles

guest
3 Comments
Newest
Oldest Most Voted
Inline Feedbacks
View all comments